summaryrefslogtreecommitdiff
path: root/recordmydesktop/configure.ac
diff options
context:
space:
mode:
authoriovar <iovar@f606c939-3180-4ac9-a4b8-4b8779d57d0a>2007-02-07 18:44:02 +0000
committeriovar <iovar@f606c939-3180-4ac9-a4b8-4b8779d57d0a>2007-02-07 18:44:02 +0000
commit9c05582a007788295d872172c5109ae9bccfcf68 (patch)
tree6c2275255f4c38d819b27da2978e7f74715c8050 /recordmydesktop/configure.ac
parentf39f779f299cd78a574999830699e30f92932f06 (diff)
Added support for recording audio through jack.
libjack is dlopened so there's no runtime dependency on it. Ports must be connected at startup. New files: src/rmd_jack.c git-svn-id: https://recordmydesktop.svn.sourceforge.net/svnroot/recordmydesktop/trunk@273 f606c939-3180-4ac9-a4b8-4b8779d57d0a
Diffstat (limited to 'recordmydesktop/configure.ac')
-rw-r--r--recordmydesktop/configure.ac44
1 files changed, 36 insertions, 8 deletions
diff --git a/recordmydesktop/configure.ac b/recordmydesktop/configure.ac
index cfd413d..1826d5f 100644
--- a/recordmydesktop/configure.ac
+++ b/recordmydesktop/configure.ac
@@ -33,13 +33,21 @@ if test "x$x_includes" != "x" && test "x$x_includes" != xNONE ; then
fi
AC_ARG_ENABLE(oss,
- [ --enable-oss[=yes] compile with OSS(don't check for ALSA))],
+ [ --enable-oss[=yes] compile with OSS(don't check for ALSA)],
[case "${enableval}" in
yes) oss=true ;;
no) oss=false ;;
*) AC_MSG_ERROR(bad value ${enableval} for --enable-oss) ;;
esac],[oss=false])
+AC_ARG_ENABLE(jack,
+ [ --enable-jack[=yes] compile with Jack support],
+ [case "${enableval}" in
+ yes) jack=true ;;
+ no) jack=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-jack) ;;
+ esac],[jack=true])
+
AC_CHECK_HEADER([alsa/asoundlib.h])
AC_CHECK_HEADER([endian.h],default_endian=true)
if test x$default_endian != xtrue; then
@@ -47,7 +55,14 @@ AC_CHECK_HEADER([machine/endian.h],
AC_DEFINE([HAVE_MACHINE_ENDIAN_H],1,
endian.h in $include_path/machine/ subdirectory))
fi
+
AC_CHECK_HEADER([sys/soundcard.h])
+AC_CHECK_HEADER([dlfcn.h],[dlfcn_header=true])
+
+if test x$jack = xtrue && test x$dlfcn_header = xtrue; then
+AC_CHECK_HEADER([jack/jack.h],
+ jack_headers_present=true)
+fi
AC_CHECK_HEADERS([sys/time.h unistd.h vorbis/vorbisfile.h fcntl.h])
@@ -80,6 +95,7 @@ AC_CHECK_LIB([theora],[theora_encode_YUVin],,
AC_MSG_ERROR([Can't find libtheora]))
AC_CHECK_LIB([pthread],[pthread_mutex_lock],,
AC_MSG_ERROR([Can't find libpthread]))
+
if test x$oss = xfalse; then
AC_CHECK_LIB([asound],[snd_pcm_drain],,
audio_backend="OSS")
@@ -87,6 +103,14 @@ else
audio_backend="OSS"
fi
+if test x$jack_headers_present = xtrue; then
+ AC_CHECK_LIB([dl],[dlopen],,libdl_np=true)
+ if test x$libdl_np != xtrue; then
+ AC_DEFINE([HAVE_JACK_H],1,
+ define to 1 if <jack/jack.h> exists)
+ fi
+fi
+
# Checks for typedefs, structures, and compiler characteristics.
@@ -100,17 +124,21 @@ AC_CONFIG_FILES([Makefile
doc/Makefile ])
AC_OUTPUT
-echo ""
-echo ""
+if test x$audio_backend != xOSS; then
+ audio_backend="ALSA"
+fi
+if test x$jack_headers_present = xtrue && test x$libdl_np != xtrue; then
+ jack_support="Enabled"
+else
+ jack_support="Disabled"
+fi
echo ""
echo ""
echo "****************************************"
echo ""
-if test x$audio_backend = xOSS; then
- echo "Audio driver that will be used: OSS"
-else
- echo "Audio driver that will be used: ALSA"
-fi
+echo "Audio driver that will be used: $audio_backend"
+echo ""
+echo "Compile with Jack support: $jack_support"
echo ""
echo "****************************************"
echo ""
© All Rights Reserved