summaryrefslogtreecommitdiff
path: root/recordmydesktop/configure.ac
diff options
context:
space:
mode:
authoriovar <iovar@f606c939-3180-4ac9-a4b8-4b8779d57d0a>2008-11-15 21:04:13 +0000
committeriovar <iovar@f606c939-3180-4ac9-a4b8-4b8779d57d0a>2008-11-15 21:04:13 +0000
commit9a74509219f0493546b86960058bdcfa17ab42f2 (patch)
treea75d0ee70687d2d6fb0e88ab108f9a60840b1f0c /recordmydesktop/configure.ac
parentf54124e18ec18c7a97db7221e2a2ba23313e5ff4 (diff)
configure.ac, doc/recordmydesktop.1, src/rmd.c, src/rmd_cache_audio.c, src/rmd_encode_sound_buffer.c, src/rmd_initialize_data.c, src/rmd_jack.c, src/rmd_jack.h, src/rmd_parseargs.c, src/rmd_threads.c, src/rmd_types.h: Changed the way Jack support is offered, from dlopening at runtime to normal linking at compilation. git-svn-id: https://recordmydesktop.svn.sourceforge.net/svnroot/recordmydesktop/trunk@569 f606c939-3180-4ac9-a4b8-4b8779d57d0a
Diffstat (limited to 'recordmydesktop/configure.ac')
-rw-r--r--recordmydesktop/configure.ac30
1 files changed, 7 insertions, 23 deletions
diff --git a/recordmydesktop/configure.ac b/recordmydesktop/configure.ac
index 7cff3df..1410f70 100644
--- a/recordmydesktop/configure.ac
+++ b/recordmydesktop/configure.ac
@@ -60,12 +60,7 @@ AC_CHECK_HEADER([machine/endian.h],
fi
AC_CHECK_HEADER([sys/soundcard.h])
-AC_CHECK_HEADER([dlfcn.h],[dlfcn_header=true])
-if test x$jack = xtrue && test x$dlfcn_header = xtrue; then
-AC_CHECK_HEADER([jack/jack.h],
- jack_headers_present=true)
-fi
AC_CHECK_HEADERS([sys/time.h unistd.h vorbis/vorbisfile.h fcntl.h])
@@ -99,6 +94,11 @@ AC_CHECK_LIB([theora],[theora_encode_YUVin],,
AC_CHECK_LIB([pthread],[pthread_mutex_lock],,
AC_MSG_ERROR([Can't find libpthread]))
+if test x$jack = xtrue ; then
+AC_CHECK_LIB([jack],[jack_activate],,
+ jack_lib_found=false)
+fi
+
if test x$oss = xfalse; then
AC_CHECK_LIB([asound],[snd_pcm_drain],,
audio_backend="OSS")
@@ -106,23 +106,6 @@ else
audio_backend="OSS"
fi
-if test x$jack_headers_present = xtrue; then
- case "$host_os" in
- *bsd*)
- AC_CHECK_LIB([c], [dlopen],,libdl_np=true)
- ;;
- *)
- AC_CHECK_LIB([dl],[dlopen],,libdl_np=true)
- ;;
- esac
-
- if test x$libdl_np != xtrue; then
- AC_DEFINE([HAVE_JACK_H],1,
- define to 1 if <jack/jack.h> exists)
- fi
-fi
-
-
# Checks for typedefs, structures, and compiler characteristics.
# Checks for library functions.
@@ -137,7 +120,8 @@ AC_OUTPUT
if test x$audio_backend != xOSS; then
audio_backend="ALSA"
fi
-if test x$jack_headers_present = xtrue && test x$libdl_np != xtrue; then
+if test x$jack_lib_found != xfalse ; then
+# AC_DEFINE([HAVE_JACK_H],1,define to 1 if libjack is found) ,
jack_support="Enabled"
else
jack_support="Disabled"
© All Rights Reserved