summaryrefslogtreecommitdiff
path: root/recordmydesktop/configure.ac
diff options
context:
space:
mode:
authorbiocrasher <biocrasher@f606c939-3180-4ac9-a4b8-4b8779d57d0a>2006-07-29 00:46:08 +0000
committerbiocrasher <biocrasher@f606c939-3180-4ac9-a4b8-4b8779d57d0a>2006-07-29 00:46:08 +0000
commit64ff67035858551a9e789714ddbeba235b61cace (patch)
treedb0ed47cc8853b0102e92dca90f6ce179d66eb7a /recordmydesktop/configure.ac
parent2ac4187271140d5c8cafd69233b09f3350878663 (diff)
added ac_path_xtra macro
git-svn-id: https://recordmydesktop.svn.sourceforge.net/svnroot/recordmydesktop/trunk@28 f606c939-3180-4ac9-a4b8-4b8779d57d0a
Diffstat (limited to 'recordmydesktop/configure.ac')
-rw-r--r--recordmydesktop/configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/recordmydesktop/configure.ac b/recordmydesktop/configure.ac
index a5875c4..2beab33 100644
--- a/recordmydesktop/configure.ac
+++ b/recordmydesktop/configure.ac
@@ -20,19 +20,24 @@ AC_HEADER_DIRENT
AC_HEADER_STDC
AC_PATH_X
+AC_PATH_XTRA
+
AC_CHECK_HEADER([png.h])
AC_CHECK_HEADER([alsa/asoundlib.h])
AC_CHECK_HEADERS([sys/time.h unistd.h vorbis/vorbisfile.h ])
-LDFLAGS="$LD_FLAGS -L$x_libraries "
+LDFLAGS="$LD_FLAGS -L$x_libraries $X_LIBS $X_EXTRA_LIBS $X_PRE_LIBS"
CFLAGS="${CFLAGS} -O3 -Wall -D_THREAD_SAFE -pthread"
+
+
# Checks for libraries.
AC_CHECK_LIB([m],[isnan],,)
AC_CHECK_LIB([z],[deflate],,)
-AC_CHECK_LIB([X11],[XOpenDisplay],,AC_MSG_ERROR([Can't find libX11]))
+AC_CHECK_LIB([X11],[XOpenDisplay],,AC_MSG_ERROR([Can't find libX11]),
+ -L$x_libraries $X_PRE_LIBS)
AC_CHECK_LIB([Xext],[XShmQueryVersion],,AC_MSG_ERROR([Can't find libXext]))
AC_CHECK_LIB([Xdamage], [XDamageQueryExtension],,AC_MSG_ERROR([Can't find libXdamage]))
AC_CHECK_LIB([vorbis],[vorbis_info_clear],,AC_MSG_ERROR([Can't find libvorbis]))
© All Rights Reserved