summaryrefslogtreecommitdiff
path: root/rMD-exp/configure.ac
diff options
context:
space:
mode:
authoriovar <iovar@f606c939-3180-4ac9-a4b8-4b8779d57d0a>2006-10-06 14:14:57 +0000
committeriovar <iovar@f606c939-3180-4ac9-a4b8-4b8779d57d0a>2006-10-06 14:14:57 +0000
commitf9563ee14b530fa38701b00d551891a6bdcd0352 (patch)
tree910062fa0beff896335d0bd8040713a3c5e140a5 /rMD-exp/configure.ac
parent59a690e87883e1da1256cbf72085b6830a2e99ff (diff)
This commit was generated by cvs2svn to compensate for changes in r85,
which included commits to RCS files with non-trunk default branches. git-svn-id: https://recordmydesktop.svn.sourceforge.net/svnroot/recordmydesktop/trunk@86 f606c939-3180-4ac9-a4b8-4b8779d57d0a
Diffstat (limited to 'rMD-exp/configure.ac')
-rw-r--r--rMD-exp/configure.ac66
1 files changed, 66 insertions, 0 deletions
diff --git a/rMD-exp/configure.ac b/rMD-exp/configure.ac
new file mode 100644
index 0000000..6850723
--- /dev/null
+++ b/rMD-exp/configure.ac
@@ -0,0 +1,66 @@
+ # -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(src/recordmydesktop.c)
+AM_INIT_AUTOMAKE(recordmydesktop,0.2.6,)
+
+AC_CONFIG_SRCDIR([src/recordmydesktop.c])
+AM_CONFIG_HEADER(config.h)
+
+
+
+# Checks for programs.
+
+AC_PROG_CC
+
+# Checks for header files.
+
+AC_HEADER_DIRENT
+AC_HEADER_STDC
+
+AC_PATH_X
+AC_PATH_XTRA
+
+AC_CHECK_HEADER([png.h])
+AC_CHECK_HEADER([alsa/asoundlib.h])
+AC_CHECK_HEADERS([sys/time.h unistd.h vorbis/vorbisfile.h ])
+
+LDFLAGS="$LD_FLAGS -L$x_libraries $X_LIBS $X_EXTRA_LIBS $X_PRE_LIBS"
+
+#no-O3s-thx.patch ;)
+CFLAGS="${CFLAGS} -Wall -D_THREAD_SAFE -pthread"
+
+
+
+
+# Checks for libraries.
+
+AC_CHECK_LIB([m],[isnan],,)
+AC_CHECK_LIB([z],[deflate],,)
+AC_CHECK_LIB([X11],[XOpenDisplay],,AC_MSG_ERROR([Can't find libX11]),
+ -L$x_libraries $X_PRE_LIBS)
+AC_CHECK_LIB([Xext],[XShmQueryVersion],,AC_MSG_ERROR([Can't find libXext]))
+AC_CHECK_LIB([Xfixes], [XFixesQueryExtension],,AC_MSG_ERROR([Can't find libXfixes]))
+AC_CHECK_LIB([Xdamage], [XDamageQueryExtension],,AC_MSG_ERROR([Can't find libXdamage]))
+AC_CHECK_LIB([vorbis],[vorbis_info_clear],,AC_MSG_ERROR([Can't find libvorbis]))
+AC_CHECK_LIB([vorbisfile],[ov_open],,AC_MSG_ERROR([Can't find libvorbisfile]),-lvorbis)
+AC_CHECK_LIB([vorbisenc],[vorbis_encode_init],,AC_MSG_ERROR([Can't find libvorbisenc]),-lvorbis)
+AC_CHECK_LIB([ogg],[ogg_stream_init],,AC_MSG_ERROR([Can't find libogg]))
+AC_CHECK_LIB([theora],[theora_encode_YUVin],,AC_MSG_ERROR([Can't find libtheora]))
+AC_CHECK_LIB([pthread],[pthread_mutex_lock],,AC_MSG_ERROR([Can't find libpthread]))
+
+AC_CHECK_LIB([asound],[snd_pcm_drain],,AC_MSG_ERROR([Can't find libasound]))
+
+
+# Checks for typedefs, structures, and compiler characteristics.
+
+# Checks for library functions.
+AC_FUNC_CLOSEDIR_VOID
+AC_FUNC_MALLOC
+
+AC_CONFIG_FILES([Makefile
+ src/Makefile
+ doc/Makefile ])
+AC_OUTPUT
+
© All Rights Reserved