summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2021-08-23 15:34:12 -0700
committerVito Caputo <vcaputo@pengaru.com>2021-08-24 00:48:46 -0700
commitdb549aa7f63621e1b81d32e59456303c5003b4b9 (patch)
tree277d51fca2c89e2fdf7002ffee051bcd70b21ef8 /src/Makefile.am
parentb53cc8e61a27f948df5f11da07c7c395ebae1dd1 (diff)
verify-hashed-objects: add `jio verify hashed-objects`
This is currently very hacky and unfinished, but does enough for some performance comparisons against a zstd-using journalctl --verify that has been hacked to return early after the first pass. It's currently rather leaky, the whole per-object-dispatch thingy is illuminating a thunk_h shortcoming and forcing addressing the issue... soon.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 92f89b8..e0c25d1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -22,7 +22,9 @@ jio_SOURCES = \
report-tail-waste.c \
report-tail-waste.h \
report-usage.c \
- report-usage.h
+ report-usage.h \
+ verify-hashed-objects.c \
+ verify-hashed-objects.h
jio_CPPFLAGS = -I@top_srcdir@/thunk_h -I@top_srcdir@/libiou/src
jio_LDADD = @top_builddir@/libiou/src/libiou.a @top_builddir@/src/upstream/libupstream.a
© All Rights Reserved