summaryrefslogtreecommitdiff
path: root/src/modules/ray/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2018-03-19 22:06:16 -0700
committerVito Caputo <vcaputo@pengaru.com>2018-03-19 22:06:16 -0700
commitb328cf5313b53652be2405113daa60e7ce745311 (patch)
tree09b7178d1815a4f2a43b80b020947cd2e02ca86c /src/modules/ray/Makefile.am
parentb5bc962e834992eeba2abdd10f6e37ee2ba20295 (diff)
modules/ray: #include libray headers w/subdirs
Rather than require adding -Isrc/libs/$lib to every Makefile.am for every lib used, just add -Ilibs to those makefiles and prefix the lib dir in the #include <> header paths. Later I'll probably just move the -Isrc/libs someplace common so the per-module Makefile.am doesn't need to bother with this stuff.
Diffstat (limited to 'src/modules/ray/Makefile.am')
-rw-r--r--src/modules/ray/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/modules/ray/Makefile.am b/src/modules/ray/Makefile.am
index 5fec057..637a921 100644
--- a/src/modules/ray/Makefile.am
+++ b/src/modules/ray/Makefile.am
@@ -1,4 +1,4 @@
noinst_LIBRARIES = libray.a
libray_a_SOURCES = ray.c
libray_a_CFLAGS = -ffast-math
-libray_a_CPPFLAGS = -I@top_srcdir@/src -I@top_srcdir@/src/libs/ray
+libray_a_CPPFLAGS = -I@top_srcdir@/src -I@top_srcdir@/src/libs
© All Rights Reserved