summaryrefslogtreecommitdiff
path: root/src/modules/ray/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2018-03-19 21:39:09 -0700
committerVito Caputo <vcaputo@pengaru.com>2018-03-19 22:02:08 -0700
commitb5bc962e834992eeba2abdd10f6e37ee2ba20295 (patch)
tree11bf58a64208806817c0fcab481588086297ce6c /src/modules/ray/Makefile.am
parent3b9a4861d6937a66b03791b5b497e47c52189a7d (diff)
ray: libize raytracer core, introduces src/libs
This is the first step of breaking out all the core rendering stuffs into reusable libraries and making modules purely compositional, consumers of various included rendering/effects libraries. Expect multiple modules leveraging libray for a variety of scenes and such. Also expect compositions mixing the various libraries for more interesting visuals.
Diffstat (limited to 'src/modules/ray/Makefile.am')
-rw-r--r--src/modules/ray/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/modules/ray/Makefile.am b/src/modules/ray/Makefile.am
index 6c5900a..5fec057 100644
--- a/src/modules/ray/Makefile.am
+++ b/src/modules/ray/Makefile.am
@@ -1,4 +1,4 @@
noinst_LIBRARIES = libray.a
-libray_a_SOURCES = ray_3f.h ray.c ray_camera.c ray_camera.h ray_color.h ray_euler.c ray_euler.h ray_light_emitter.h ray_object.h ray_object_light.h ray_object_plane.h ray_object_point.h ray_object_sphere.h ray_object_type.h ray_ray.h ray_render.c ray_render.h ray_render_object.h ray_render_object_plane.h ray_render_object_point.h ray_render_object_sphere.h ray_scene.h ray_surface.h
+libray_a_SOURCES = ray.c
libray_a_CFLAGS = -ffast-math
-libray_a_CPPFLAGS = -I@top_srcdir@/src
+libray_a_CPPFLAGS = -I@top_srcdir@/src -I@top_srcdir@/src/libs/ray
© All Rights Reserved