summaryrefslogtreecommitdiff
path: root/src/modules/ray/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@gnugeneration.com>2017-02-10 07:55:51 -0800
committerVito Caputo <vcaputo@gnugeneration.com>2017-02-10 08:18:11 -0800
commit35d8587b8e6b5a85fe0f978ff8cd5a899a8ff6a4 (patch)
tree9ec99df685acefa0df3530322bf7221c49227339 /src/modules/ray/Makefile.am
parenta4914d40fd9e25fa4c02af8d4c02d227064c1903 (diff)
ray: implement all orders in ray_euler_basis()
Originally I only implemented pitch->yaw->roll, and being new to all this didn't fully appreciate the limitation that resulted in. This adds all six permutations of pitch/yaw/roll, the scene must specify the desired order when setting up the camera with the euler angles, see the enum in ray_euler.h.
Diffstat (limited to 'src/modules/ray/Makefile.am')
-rw-r--r--src/modules/ray/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/modules/ray/Makefile.am b/src/modules/ray/Makefile.am
index 6c9a50a..7acfdd8 100644
--- a/src/modules/ray/Makefile.am
+++ b/src/modules/ray/Makefile.am
@@ -1,4 +1,4 @@
noinst_LIBRARIES = libray.a
-libray_a_SOURCES = ray_3f.h ray.c ray_camera.c ray_camera.h ray_color.h ray_euler.h ray.h ray_light_emitter.h ray_object.c ray_object.h ray_object_light.h ray_object_plane.h ray_object_point.h ray_object_sphere.h ray_object_type.h ray_ray.h ray_scene.c ray_scene.h ray_surface.h ray_threads.c ray_threads.h
+libray_a_SOURCES = ray_3f.h ray.c ray_camera.c ray_camera.h ray_color.h ray_euler.c ray_euler.h ray.h ray_light_emitter.h ray_object.c ray_object.h ray_object_light.h ray_object_plane.h ray_object_point.h ray_object_sphere.h ray_object_type.h ray_ray.h ray_scene.c ray_scene.h ray_surface.h ray_threads.c ray_threads.h
libray_a_CFLAGS = @ROTOTILLER_CFLAGS@ -ffast-math
libray_a_CPPFLAGS = @ROTOTILLER_CFLAGS@ -I@top_srcdir@/src
© All Rights Reserved