summaryrefslogtreecommitdiff
path: root/recordmydesktop/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'recordmydesktop/configure.ac')
-rw-r--r--recordmydesktop/configure.ac23
1 files changed, 14 insertions, 9 deletions
diff --git a/recordmydesktop/configure.ac b/recordmydesktop/configure.ac
index 4c6ae69..c8dae65 100644
--- a/recordmydesktop/configure.ac
+++ b/recordmydesktop/configure.ac
@@ -3,7 +3,7 @@
AC_PREREQ(2.59)
AC_INIT(src/recordmydesktop.c)
-AM_INIT_AUTOMAKE(recordmydesktop,0.2.7,)
+AM_INIT_AUTOMAKE(recordmydesktop,0.3.0,)
AC_CONFIG_SRCDIR([src/recordmydesktop.c])
AM_CONFIG_HEADER(config.h)
@@ -22,22 +22,27 @@ AC_HEADER_STDC
AC_PATH_X
AC_PATH_XTRA
-AC_CHECK_HEADER([png.h])
-AC_CHECK_HEADER([alsa/asoundlib.h])
-AC_CHECK_HEADERS([sys/time.h unistd.h vorbis/vorbisfile.h ])
+if test "x$x_libraries" != "x" && test "x$x_libraries" != xNONE ; then
+ echo "X libraries are found in $x_libraries"
+ LIBS="-L$x_libraries $LIBS";
+fi
-LDFLAGS="$LD_FLAGS -L$x_libraries $X_LIBS $X_EXTRA_LIBS $X_PRE_LIBS"
-
-#no-O3s-thx.patch ;)
-CFLAGS="${CFLAGS} -Wall -D_THREAD_SAFE -pthread"
+if test "x$x_includes" != "x" && test "x$x_includes" != xNONE ; then
+ echo "X includes are found in $x_includes"
+ CFLAGS="-I$x_includes $CFLAGS";
+fi
+AC_CHECK_HEADER([alsa/asoundlib.h])
+AC_CHECK_HEADERS([sys/time.h unistd.h vorbis/vorbisfile.h ])
# Checks for libraries.
AC_CHECK_LIB([m],[isnan],,)
AC_CHECK_LIB([z],[deflate],,)
+AC_CHECK_LIB([ICE],[IceOpenConnection],,AC_MSG_ERROR([Can't find libICE]),)
+AC_CHECK_LIB([SM],[SmcOpenConnection],,AC_MSG_ERROR([Can't find libSM]),)
AC_CHECK_LIB([X11],[XOpenDisplay],,AC_MSG_ERROR([Can't find libX11]),
-L$x_libraries $X_PRE_LIBS)
AC_CHECK_LIB([Xext],[XShmQueryVersion],,AC_MSG_ERROR([Can't find libXext]))
@@ -49,10 +54,10 @@ AC_CHECK_LIB([vorbisenc],[vorbis_encode_init],,AC_MSG_ERROR([Can't find libvorbi
AC_CHECK_LIB([ogg],[ogg_stream_init],,AC_MSG_ERROR([Can't find libogg]))
AC_CHECK_LIB([theora],[theora_encode_YUVin],,AC_MSG_ERROR([Can't find libtheora]))
AC_CHECK_LIB([pthread],[pthread_mutex_lock],,AC_MSG_ERROR([Can't find libpthread]))
-
AC_CHECK_LIB([asound],[snd_pcm_drain],,AC_MSG_ERROR([Can't find libasound]))
+
# Checks for typedefs, structures, and compiler characteristics.
# Checks for library functions.
© All Rights Reserved