summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2020-11-11 23:44:15 -0800
committerVito Caputo <vcaputo@pengaru.com>2020-11-12 23:14:05 -0800
commitc265f13978fbd68f295d99b2fe4720fe4866d64c (patch)
treea08822aa66dd16bb3ef79d7e46706386db02ddcc /src/Makefile.am
parent7281dc6fdc4f345c9c1c7bcda20e3bef3003c140 (diff)
timer: remove unnecessary timer thread
This removes the timer thread entirely in favor of a coordinated delay loop directly within rmdGetFrame. When there's an audio stream to synchronize with, avd is maintained by the pcm buffer updates, and the fps-derived frametimes synchronize with the audio that way. When there's no audio stream (--no-sound), avd is now maintained synthetically via clock_gettime(CLOCK_MONOTONIC) coordinating with the clock instead. There's been some reworking of frame sampling/reusing and cloning logic, which may need some refinement. But for now the tests seem to show promise. The old timer approach just increased the non-determinism by adding more scheduler latency and influence unnecessarily.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ba429cb..78b8d7e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -61,8 +61,6 @@ recordmydesktop_SOURCES = \
rmd_specsfile.h \
rmd_threads.c \
rmd_threads.h \
- rmd_timer.c \
- rmd_timer.h \
rmd_types.h \
rmd_update_image.c \
rmd_update_image.h \
© All Rights Reserved