summaryrefslogtreecommitdiff
path: root/recordmydesktop/src/Makefile.am
diff options
context:
space:
mode:
authorenselic <enselic@f606c939-3180-4ac9-a4b8-4b8779d57d0a>2008-09-13 21:35:43 +0000
committerenselic <enselic@f606c939-3180-4ac9-a4b8-4b8779d57d0a>2008-09-13 21:35:43 +0000
commit2cf3c4864635a5761c5a9f45857abeb9ac363dcd (patch)
tree62a436d611485195a5f2c554e0741d45972879c5 /recordmydesktop/src/Makefile.am
parent700ec4aebc1ea833b2f7b50bff3aba119913b355 (diff)
include/rmdmacro.h
include/rmdtypes.h include/skeleton.h include/recordmydesktop.h: Moved from here src/rmdmacro.h src/rmdtypes.h src/skeleton.h src/recordmydesktop.h: to here. include include/Makefile.am: Removed, no need for a separate include dir. Makefile.am configure.ac src/Makefile.am: Adjusted accordingly. git-svn-id: https://recordmydesktop.svn.sourceforge.net/svnroot/recordmydesktop/trunk@539 f606c939-3180-4ac9-a4b8-4b8779d57d0a
Diffstat (limited to 'recordmydesktop/src/Makefile.am')
-rw-r--r--recordmydesktop/src/Makefile.am18
1 files changed, 8 insertions, 10 deletions
diff --git a/recordmydesktop/src/Makefile.am b/recordmydesktop/src/Makefile.am
index 4c80b7c..c77a83e 100644
--- a/recordmydesktop/src/Makefile.am
+++ b/recordmydesktop/src/Makefile.am
@@ -36,6 +36,7 @@ recordmydesktop_SOURCES = \
queryextensions.c \
queryextensions.h \
recordmydesktop.c \
+ recordmydesktop.h \
rectinsert.c \
rectinsert.h \
register_callbacks.c \
@@ -54,11 +55,14 @@ recordmydesktop_SOURCES = \
rmd_timer.h \
rmdthreads.c \
rmdthreads.h \
+ rmdmacro.h \
+ rmdtypes.h \
setbrwindow.c \
setbrwindow.h \
shortcuts.c \
shortcuts.h \
skeleton.c \
+ skeleton.h \
specsfile.c \
specsfile.h \
update_image.c \
@@ -68,17 +72,14 @@ recordmydesktop_SOURCES = \
wm_check.c \
wm_check.h
-
-INCLUDES = $(all_includes) -I$(top_srcdir)/include
-
-recordmydesktop_LDFLAGS = @X_LIBS@ @X_EXTRA_LIBS@ @X_PRE_LIBS@
-recordmydesktop_CFLAGS = -D_THREAD_SAFE -pthread -Wall
+recordmydesktop_CPPFLAGS = -D_THREAD_SAFE -pthread -Wall
+recordmydesktop_LDFLAGS = @X_LIBS@ @X_EXTRA_LIBS@ @X_PRE_LIBS@
# RectInsert test
-TESTS = test-rectinsert
+TESTS = test-rectinsert
EXTRA_PROGRAMS = test-rectinsert
-CLEANFILES = $(EXTRA_PROGRAMS)
+CLEANFILES = $(EXTRA_PROGRAMS)
test_rectinsert_SOURCES = \
test-rectinsert.c \
@@ -87,7 +88,4 @@ test_rectinsert_SOURCES = \
test-rectinsert-types.h \
rectinsert.c
-test_rectinsert_CPPFLAGS = \
- -I$(top_srcdir)/include
-
test_rectinsert_CFLAGS = -Wall
© All Rights Reserved