summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2021-09-26 18:09:14 -0700
committerVito Caputo <vcaputo@pengaru.com>2021-09-26 18:13:28 -0700
commit1b26c9e5b8fcda39ecffbe56e3dd8d90c9b6fe4a (patch)
treeec343bb97325ac6ebb5f574e8408bf951acdd8a5 /src/Makefile.am
parentaac6a90282480d6dfed7876586b582094371b934 (diff)
pig: implement rudimentary GNU Rocket integrationHEADmaster
This creates GNU Rocket tracks for all active float uniforms in the loaded shaders. Simply start a GNU Rocket editor listening on the standard port @ localhost, and the tracks should appear. The automatic setting of these uniforms becomes overriden by the track values, which can be annoying.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b6bf5f0..0f809dc 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -23,5 +23,5 @@ pig_SOURCES = \
v3f.h \
v4f.h
-pig_CPPFLAGS = -I@top_srcdir@/libstage/src -I@top_srcdir@/libplay/src -ffast-math
-pig_LDADD = @top_builddir@/libstage/src/libstage.a @top_builddir@/libplay/src/libplay.a -lm -ldl
+pig_CPPFLAGS = -I@top_srcdir@/libplay/src -I@top_srcdir@/librocket/rocket/lib -I@top_srcdir@/libstage/src -ffast-math
+pig_LDADD = @top_builddir@/libplay/src/libplay.a @top_builddir@/librocket/librocket.a @top_builddir@/libstage/src/libstage.a -lm -ldl
© All Rights Reserved