summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2021-08-23 15:34:12 -0700
committerVito Caputo <vcaputo@pengaru.com>2021-08-24 00:48:46 -0700
commitdb549aa7f63621e1b81d32e59456303c5003b4b9 (patch)
tree277d51fca2c89e2fdf7002ffee051bcd70b21ef8 /configure.ac
parentb53cc8e61a27f948df5f11da07c7c395ebae1dd1 (diff)
verify-hashed-objects: add `jio verify hashed-objects`
This is currently very hacky and unfinished, but does enough for some performance comparisons against a zstd-using journalctl --verify that has been hacked to return early after the first pass. It's currently rather leaky, the whole per-object-dispatch thingy is illuminating a thunk_h shortcoming and forcing addressing the issue... soon.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f164223..99c66d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,11 @@ PKG_CHECK_MODULES(CRYPTO, libcrypto)
CFLAGS="$CFLAGS $CRYPTO_CFLAGS"
LIBS="$LIBS $CRYPTO_LIBS"
+dnl Check for libztsd
+PKG_CHECK_MODULES(ZSTD, libzstd)
+CFLAGS="$CFLAGS $ZSTD_CFLAGS"
+LIBS="$LIBS $ZSTD_LIBS"
+
AC_CONFIG_SUBDIRS([
libiou
])
© All Rights Reserved