summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2021-08-14 18:15:50 -0700
committerVito Caputo <vcaputo@pengaru.com>2021-08-14 18:18:07 -0700
commitacf6b48fbba3c076839e55ceb426d1a54aa750f9 (patch)
treedf56b416c9f2a6b124952944e31e4e2c6f45077b /configure.ac
parent68be4ecfbad5a3ccae5866572e802d1f0f72d7d0 (diff)
build: add libcrypto dependency
Preparatory commit for report-entry-arrays, I used libcrypto for SHA1 "perfect" hashing of the payloads. This way I didn't need to keep the payloads themselves around for counting duplicates, the SHA1 digests suffice.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3a88409..da6d853 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,6 +13,11 @@ PKG_CHECK_MODULES(URING, liburing)
CFLAGS="$CFLAGS $URING_CFLAGS"
LIBS="$LIBS $URING_LIBS"
+dnl Check for libcrypto
+PKG_CHECK_MODULES(CRYPTO, libcrypto)
+CFLAGS="$CFLAGS $CRYPTO_CFLAGS"
+LIBS="$LIBS $CRYPTO_LIBS"
+
AC_CONFIG_SUBDIRS([
libiou
])
© All Rights Reserved