summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2020-11-25 18:03:12 -0800
committerVito Caputo <vcaputo@pengaru.com>2020-11-25 18:07:09 -0800
commit799258ed87c526ab0ff1375bcb45df7ae28556ee (patch)
treefc6a11292524d43285ee2a9d05e4af0e6cf6c5c9 /configure.ac
parent8ec1588722809a35a7d149bff10de56424e2658a (diff)
build: introduce rudimentary autotools
Now it's easy to build even
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..3a88409
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,25 @@
+AC_INIT([jio], [0.1], [vcaputo@pengaru.com])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+AC_PROG_CC
+AM_PROG_CC_C_O
+AM_PROG_AR
+AC_PROG_RANLIB
+AM_SILENT_RULES([yes])
+
+CFLAGS="$CFLAGS -Wall"
+
+dnl Check for liburing
+PKG_CHECK_MODULES(URING, liburing)
+CFLAGS="$CFLAGS $URING_CFLAGS"
+LIBS="$LIBS $URING_LIBS"
+
+AC_CONFIG_SUBDIRS([
+ libiou
+])
+
+AC_CONFIG_FILES([
+ Makefile
+ src/Makefile
+])
+
+AC_OUTPUT
© All Rights Reserved