summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2021-08-24 17:05:43 -0700
committerVito Caputo <vcaputo@pengaru.com>2021-08-24 17:15:54 -0700
commit5dc0dff11ab1ff9ec0fc1edf22458942462fe5e3 (patch)
treeddd7560640dcaf135cd1a93c1657d85c1b410828 /configure.ac
parentb594caec30b74310d9426b155c7b20c621787a4d (diff)
libiou,thunk_h: bump for iou_async()/mt-safe thunks
libiou sprouted a thread pool, to make thunks safe for dispatching/freeing from threads thunk.h needed some compare-and-swap magic in maintaining those free lists. Since libiou pulls in pthreads now, bring pthreads in here too.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 99c66d2..8623242 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,13 +1,19 @@
AC_INIT([jio], [0.1], [vcaputo@pengaru.com])
AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+AC_CONFIG_MACRO_DIRS([m4])
AC_PROG_CC
-AM_PROG_CC_C_O
AM_PROG_AR
AC_PROG_RANLIB
AM_SILENT_RULES([yes])
CFLAGS="$CFLAGS -Wall"
+dnl pthreads for libiou's sake
+AX_PTHREAD
+LIBS="$PTHREAD_LIBS $LIBS"
+CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
+CC="$PTHREAD_CC"
+
dnl Check for liburing
PKG_CHECK_MODULES(URING, liburing)
CFLAGS="$CFLAGS $URING_CFLAGS"
© All Rights Reserved