summaryrefslogtreecommitdiff
path: root/src/modules/swab/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2019-11-18 01:55:16 -0800
committerVito Caputo <vcaputo@pengaru.com>2019-11-18 01:59:13 -0800
commit01ab4fea185b451ed2d281a21ae62ba8c85e5237 (patch)
tree01ce924ffc86627c3b98a2460584cff5902aca66 /src/modules/swab/Makefile.am
parent975c81262faa7ed06de56974064fd918a088bc1b (diff)
swab: add a perlin noise visualization
This maps a different Z-slice through the noise field to each color channel. The slices are moved up and down through the field over time, and the size of the area each color samples is tweaked a bit to make them less coherent with the noise field cells. It could be improved, but I think the output is already neat enough to be worth sharing.
Diffstat (limited to 'src/modules/swab/Makefile.am')
-rw-r--r--src/modules/swab/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/modules/swab/Makefile.am b/src/modules/swab/Makefile.am
new file mode 100644
index 0000000..4db914b
--- /dev/null
+++ b/src/modules/swab/Makefile.am
@@ -0,0 +1,3 @@
+noinst_LIBRARIES = libswab.a
+libswab_a_SOURCES = swab.c
+libswab_a_CPPFLAGS = -I@top_srcdir@/src -I@top_srcdir@/src/libs
© All Rights Reserved