summaryrefslogtreecommitdiff
path: root/src/modules/stars/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2021-02-14 22:43:08 -0800
committerVito Caputo <vcaputo@pengaru.com>2021-02-14 22:51:37 -0800
commit11b87c843e20f66bd68e02353ba4a1072e1230a6 (patch)
tree15458ff0ac2b61b51517fb26ca3cd4b148c2a96f /src/modules/stars/Makefile.am
parent950d6abb1ffd126a3200044de31b631ac987ed7e (diff)
*: split rototiller.[ch] into lib and main
This is a first approximation of separating the core modules and threaded rendering from the cli-centric rototiller program and its sdl+drm video backends. Unfortunately this seemed to require switching over to libtool archives (.la) to permit consolidating the per-lib and per-module .a files into the librototiller.a and linking just with librototiller.a to depend on the aggregate of libs+modules+librototiller-glue in a simple fashion. If an alternative to .la comes up I will switch over to it, using libtool really slows down the build process. Those are implementation/build system details though. What's important in these changes is establishing something resembling a librototiller API boundary, enabling creating alternative frontends which vendor this tree as a submodule and link just to librototiller.{la,a} for all the modules+threaded rendering of them, while providing their own fb_ops_t for outputting into, and their own settings applicators for driving the modules setup.
Diffstat (limited to 'src/modules/stars/Makefile.am')
-rw-r--r--src/modules/stars/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/modules/stars/Makefile.am b/src/modules/stars/Makefile.am
index 20ee80e..ebeb4dd 100644
--- a/src/modules/stars/Makefile.am
+++ b/src/modules/stars/Makefile.am
@@ -1,3 +1,3 @@
-noinst_LIBRARIES = libstars.a
-libstars_a_SOURCES = draw.h stars.c
-libstars_a_CPPFLAGS = -I@top_srcdir@/src
+noinst_LTLIBRARIES = libstars.la
+libstars_la_SOURCES = draw.h stars.c
+libstars_la_CPPFLAGS = -I@top_srcdir@/src
© All Rights Reserved