summaryrefslogtreecommitdiff
path: root/src/modules/ray/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2017-12-23 21:14:06 -0800
committerVito Caputo <vcaputo@pengaru.com>2017-12-23 21:17:24 -0800
commit8ab42d0fb70f5c74554350b10e35bd6b6a78ab1b (patch)
tree69c63d0962977b2db31bcb60f992ec2bff3d73f4 /src/modules/ray/Makefile.am
parent5c287c99a3fa8f137dc279b2253c628e83786afe (diff)
ray: split object render from object description
This moves the per-object _prepared state into ray_render_object_$type structs with all the rendering-related object methods switched to operate on the new render structs. Since the current rendering code just makes all these assumptions about light objects being point lights, I've just dropped all the stuff associated with rendering light objects for now. I think it will be refactored a bit later on when the rendering code stops hard-coding the point light stuff. These changes open up the possibility of constifying the scene and constituent objects, now that rendering doesn't shove the prepared state into the embedded _prepared object substructs.
Diffstat (limited to 'src/modules/ray/Makefile.am')
-rw-r--r--src/modules/ray/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/modules/ray/Makefile.am b/src/modules/ray/Makefile.am
index a0d7cb9..b62e4ba 100644
--- a/src/modules/ray/Makefile.am
+++ b/src/modules/ray/Makefile.am
@@ -1,4 +1,4 @@
noinst_LIBRARIES = libray.a
-libray_a_SOURCES = ray_3f.h ray.c ray_camera.c ray_camera.h ray_color.h ray_euler.c ray_euler.h ray_light_emitter.h ray_object.h ray_object_light.h ray_object_plane.h ray_object_point.h ray_object_sphere.h ray_object_type.h ray_ray.h ray_render.c ray_render.h ray_scene.h ray_surface.h
+libray_a_SOURCES = ray_3f.h ray.c ray_camera.c ray_camera.h ray_color.h ray_euler.c ray_euler.h ray_light_emitter.h ray_object.h ray_object_light.h ray_object_plane.h ray_object_point.h ray_object_sphere.h ray_object_type.h ray_ray.h ray_render.c ray_render.h ray_render_object.h ray_render_object_plane.h ray_render_object_point.h ray_render_object_sphere.h ray_scene.h ray_surface.h
libray_a_CFLAGS = @ROTOTILLER_CFLAGS@ -ffast-math
libray_a_CPPFLAGS = @ROTOTILLER_CFLAGS@ -I@top_srcdir@/src
© All Rights Reserved