summaryrefslogtreecommitdiff
path: root/src/modules/playit/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2023-11-05 23:27:19 -0800
committerVito Caputo <vcaputo@pengaru.com>2023-11-14 01:20:56 -0800
commit2b8feba1200ecfa231aa41aed4b6ab9b183d5a05 (patch)
treebcc67fe369e86c200ad0d4a9c7a4c099b6c4aba1 /src/modules/playit/Makefile.am
parent43a0ba4ee53fb0e351be1ef87a60191f2d755464 (diff)
modules/playit: add an .IT file music player module
Rudimentary .IT file music playback via libplayit. When seekable=on, the file is 100% pre-rendered at context create, then simply copied into the audio queue @ render_audio. When seekable=off, the file is mixed incrementally per-frame @ render_audio in max of bufsize=N_frames increments. The bufsize here basically just determines the maximum time spent rendering audio in a single go, and how much tolerance of frame delays due to slow rendering there will be before dropouts occur.
Diffstat (limited to 'src/modules/playit/Makefile.am')
-rw-r--r--src/modules/playit/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/modules/playit/Makefile.am b/src/modules/playit/Makefile.am
new file mode 100644
index 0000000..eec7be8
--- /dev/null
+++ b/src/modules/playit/Makefile.am
@@ -0,0 +1,3 @@
+noinst_LTLIBRARIES = libplayit.la
+libplayit_la_SOURCES = playit.c
+libplayit_la_CPPFLAGS = -I@top_srcdir@/src -I@top_srcdir@/src/libs/playit/src
© All Rights Reserved