summaryrefslogtreecommitdiff
path: root/src/modules/plato/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2020-09-17 01:08:57 -0700
committerVito Caputo <vcaputo@pengaru.com>2021-01-17 18:51:36 -0800
commitb02bf111ab873aad70c169e2159ee96c8aea690b (patch)
tree27317d2f05d73b15677ad000066b547832030f42 /src/modules/plato/Makefile.am
parentc962c3deb21b0faec28fdabb460649b68c250eb6 (diff)
plato: regular convex polyhedrons in 3D
plato implements very simple software-rendered 3D models of the five convex regular polyhedra / Platonic solids Some TODO items: - procedurally generate vertices at runtime - add hidden surface removal setting (Z-buffer?) - add flat shaded rendering setting - add gouraud shading, maybe phong too? - show dual polyhedra This was more about slapping together a minimal 3D wireframe software renderer than anything to do with polyhedra, convex regular polyhedra just seemed like an excellent substrate since they're so simple to model.
Diffstat (limited to 'src/modules/plato/Makefile.am')
-rw-r--r--src/modules/plato/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/modules/plato/Makefile.am b/src/modules/plato/Makefile.am
new file mode 100644
index 0000000..d0b9069
--- /dev/null
+++ b/src/modules/plato/Makefile.am
@@ -0,0 +1,3 @@
+noinst_LIBRARIES = libplato.a
+libplato_a_SOURCES = plato.c
+libplato_a_CPPFLAGS = -I@top_srcdir@/src -I@top_srcdir@/src/libs
© All Rights Reserved