summaryrefslogtreecommitdiff
path: root/src/modules/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2020-09-17 01:08:57 -0700
committerVito Caputo <vcaputo@pengaru.com>2021-01-17 18:51:36 -0800
commitb02bf111ab873aad70c169e2159ee96c8aea690b (patch)
tree27317d2f05d73b15677ad000066b547832030f42 /src/modules/Makefile.am
parentc962c3deb21b0faec28fdabb460649b68c250eb6 (diff)
plato: regular convex polyhedrons in 3D
plato implements very simple software-rendered 3D models of the five convex regular polyhedra / Platonic solids Some TODO items: - procedurally generate vertices at runtime - add hidden surface removal setting (Z-buffer?) - add flat shaded rendering setting - add gouraud shading, maybe phong too? - show dual polyhedra This was more about slapping together a minimal 3D wireframe software renderer than anything to do with polyhedra, convex regular polyhedra just seemed like an excellent substrate since they're so simple to model.
Diffstat (limited to 'src/modules/Makefile.am')
-rw-r--r--src/modules/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/modules/Makefile.am b/src/modules/Makefile.am
index 0f60d29..d2c4636 100644
--- a/src/modules/Makefile.am
+++ b/src/modules/Makefile.am
@@ -1 +1 @@
-SUBDIRS = compose drizzle flui2d julia meta2d montage pixbounce plasma ray roto rtv snow sparkler spiro stars submit swab
+SUBDIRS = compose drizzle flui2d julia meta2d montage pixbounce plasma plato ray roto rtv snow sparkler spiro stars submit swab
© All Rights Reserved