summaryrefslogtreecommitdiff
path: root/src/modules/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2019-11-14 21:35:25 -0800
committerVito Caputo <vcaputo@pengaru.com>2019-11-14 21:44:15 -0800
commitaeb6fc5986757b0186634f7106d32861dbf55c54 (patch)
tree9780f85688a6c94ea2ca5763e1bc8c433e1d997f /src/modules/Makefile.am
parent3f260bcbcd9d29457d9dbd4f27a913c8d2e5d555 (diff)
rtv: implement "Rototiller TV" renderer
This is sort of a meta renderer, as it simply renders other modules in its prepare_frame() stage. They're still threaded as the newly public rototiller_module_render() utilizes the threading machinery, it just needs to be called from the serial phase @ prepare_frame(). I'm pretty sure this module will leak memory every time it changes modules, since the existing cleanup paths for the modules hasn't needed to be thorough in the least. So that's something to fix in a later commit, go through all the modules and make sure their destroy_context() entrypoints actually cleans everything up. See the source for some rtv-specific TODOs.
Diffstat (limited to 'src/modules/Makefile.am')
-rw-r--r--src/modules/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/modules/Makefile.am b/src/modules/Makefile.am
index 83c4ac6..fa4e852 100644
--- a/src/modules/Makefile.am
+++ b/src/modules/Makefile.am
@@ -1 +1 @@
-SUBDIRS = flui2d julia pixbounce plasma ray roto sparkler stars submit
+SUBDIRS = flui2d julia pixbounce plasma ray roto rtv sparkler stars submit
© All Rights Reserved