summaryrefslogtreecommitdiff
path: root/src/modules/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2022-04-29 08:03:23 -0700
committerVito Caputo <vcaputo@pengaru.com>2022-04-29 13:30:02 -0700
commitaa77b6b96694496c46a9f99fa23ba2edbf973aa2 (patch)
tree388ba7b2f08b6f7a726cd41f8cc4f0dc1b048305 /src/modules/Makefile.am
parent34811cbe4bf6da3e6e22860890fca4c9fff71252 (diff)
modules/voronoi: voronoi diagram module
This adds a voronoi diagram module, which when used as an overlay produces a mosaic effect. Some settings: cells=N number of voronoi cells randomize={on,off} randomizes the cell locations every frame dirty={on,off} uses a faster sloppy/dithery-looking method Some TODO items: - use a more space efficient representation of the distance buffer, maybe use uint16_t relative offsets into the cells rather than pointers - capping their quantity to 64KiB - anti-alias edges between cells
Diffstat (limited to 'src/modules/Makefile.am')
-rw-r--r--src/modules/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/modules/Makefile.am b/src/modules/Makefile.am
index 92a4145..e5c9971 100644
--- a/src/modules/Makefile.am
+++ b/src/modules/Makefile.am
@@ -1 +1 @@
-SUBDIRS = blinds checkers compose drizzle flui2d julia meta2d montage pixbounce plasma plato ray roto rtv snow sparkler spiro stars submit swab swarm
+SUBDIRS = blinds checkers compose drizzle flui2d julia meta2d montage pixbounce plasma plato ray roto rtv snow sparkler spiro stars submit swab swarm voronoi
© All Rights Reserved