summaryrefslogtreecommitdiff
path: root/src/modules/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2022-05-20 21:25:39 -0700
committerVito Caputo <vcaputo@pengaru.com>2022-05-21 13:20:55 -0700
commit192a89a7f9f396fff4eb6b0836f597c376e98932 (patch)
tree69d8da7758b4587fdfa8646ebf53d0aac277e876 /src/modules/Makefile.am
parent04553f39b81db2cf07c32a94665c7ab65a420a5c (diff)
modules/shapes: add procedural 2D shapes module
Mostly for compositing purposes, here will be a corpus of 2D shapes, parameterized/procedurally generated and able to rotate and perhaps have other dynamics added. What shapes are there presently I had started implementing in checkers as "styles", before realizing they really should just be a separate module checkers can call into. Not terribly interesting by itself, but as blinds and checkers demonstrated, these things deliver a lot of value in compositional situations. They're creating the palette to draw from.
Diffstat (limited to 'src/modules/Makefile.am')
-rw-r--r--src/modules/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/modules/Makefile.am b/src/modules/Makefile.am
index e5c9971..d00ac7b 100644
--- a/src/modules/Makefile.am
+++ b/src/modules/Makefile.am
@@ -1 +1 @@
-SUBDIRS = blinds checkers compose drizzle flui2d julia meta2d montage pixbounce plasma plato ray roto rtv snow sparkler spiro stars submit swab swarm voronoi
+SUBDIRS = blinds checkers compose drizzle flui2d julia meta2d montage pixbounce plasma plato ray roto rtv shapes snow sparkler spiro stars submit swab swarm voronoi
© All Rights Reserved