summaryrefslogtreecommitdiff
path: root/src/libs/sig/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2020-02-03 00:29:09 -0800
committerVito Caputo <vcaputo@pengaru.com>2020-02-03 00:37:50 -0800
commitba74a824658f7f59add288d28006ff48bf46b963 (patch)
treede09e33f3487a20319863bdae964f4ad5c3b5666 /src/libs/sig/Makefile.am
parentf07b311173e1231f6c0c85a47d6068de7aa00761 (diff)
libs/sig: introduce a signal generator abstraction
This adds a small framework of sorts for creating and composing signal generators. Two generators are implemented at this time; sig_ops_sin and sig_ops_mult sig_ops_sin accepts a hz variable and will produce a sine wave of that frequency. sig_ops_mult accepts two sig_t generators and multiplies their outputs Callers may construct their own sig_ops_t ops structs and supply them to sig_new(), but it's expected that libs/sig will grow a collection of commonly used generators which can then be used by simply passing their sig_ops_$foo to sig_new(). See the test code at the bottom of libs/sig/sig.c for some contrived sample usage. Note by composing multiple sig_ops_sin generators with a sig_ops_mult generator, one can already easily construct a synth-like LFO generator. Some obvious todos are to add triangle/sawtooth/square wave generators. More compositional generators may be interesting as well, like additive and subtractive for example. Those will need to implement clipping, as it's expected that the generators *always* stay within unity (0-1). No modules use this yet, but I expect to wire this up to rtv for driving knobs.
Diffstat (limited to 'src/libs/sig/Makefile.am')
-rw-r--r--src/libs/sig/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/libs/sig/Makefile.am b/src/libs/sig/Makefile.am
new file mode 100644
index 0000000..4787b5a
--- /dev/null
+++ b/src/libs/sig/Makefile.am
@@ -0,0 +1,3 @@
+noinst_LIBRARIES = libsig.a
+libsig_a_SOURCES = ops_mult.c ops_sin.c sig.c sig.h
+libsig_a_CPPFLAGS = -I@top_srcdir@/src
© All Rights Reserved