summaryrefslogtreecommitdiff
path: root/src/libs/sig/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2020-02-03 15:59:56 -0800
committerVito Caputo <vcaputo@pengaru.com>2020-02-03 16:04:18 -0800
commit59b276edf6cd3d53fab1d45819a34ef1627e3389 (patch)
tree4beb238d5fd9a10298ed99c393709c87df1cc723 /src/libs/sig/Makefile.am
parent1c1ae5ee7243e731c7b44a11400e19bb8dab047b (diff)
libs/sig: add sig_ops_scale w/test example
This assumes the input value is always 0-1, but may be used to produce values in any signed range, mapped linearly to the input.
Diffstat (limited to 'src/libs/sig/Makefile.am')
-rw-r--r--src/libs/sig/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/libs/sig/Makefile.am b/src/libs/sig/Makefile.am
index 64715fe..e53a4bd 100644
--- a/src/libs/sig/Makefile.am
+++ b/src/libs/sig/Makefile.am
@@ -1,3 +1,3 @@
noinst_LIBRARIES = libsig.a
-libsig_a_SOURCES = ops_abs.c ops_ceil.c ops_clamp.c ops_const.c ops_floor.c ops_inv.c ops_lerp.c ops_max.c ops_min.c ops_mult.c ops_pow.c ops_rand.c ops_round.c ops_sin.c sig.c sig.h
+libsig_a_SOURCES = ops_abs.c ops_ceil.c ops_clamp.c ops_const.c ops_floor.c ops_inv.c ops_lerp.c ops_max.c ops_min.c ops_mult.c ops_pow.c ops_rand.c ops_round.c ops_scale.c ops_sin.c sig.c sig.h
libsig_a_CPPFLAGS = -I@top_srcdir@/src
© All Rights Reserved