summaryrefslogtreecommitdiff
path: root/src/libs/ray/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2017-08-08 10:40:14 -0700
committerVito Caputo <vcaputo@pengaru.com>2019-11-13 02:17:54 -0800
commit8acb27a788f24f85f38cf4ca45f2c3124128fa26 (patch)
tree7b747bb9a50bf3f804ac11e03149dd347839f6fc /src/libs/ray/Makefile.am
parent448362dcd54c1275ec80d16bcb4d88732f6912f2 (diff)
ray: add rudimentary gamma correction
color banding has been quite visible, and somewhat expected with a direct conversion from the linear float color space to the 8-bit integral rgb color components. A simple lookup table is used here to non-linearly map the values, table generation is taken from Greg Ward's REAL PIXELS gem in Graphics Gems II.
Diffstat (limited to 'src/libs/ray/Makefile.am')
-rw-r--r--src/libs/ray/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/libs/ray/Makefile.am b/src/libs/ray/Makefile.am
index dc13a0d..f055d94 100644
--- a/src/libs/ray/Makefile.am
+++ b/src/libs/ray/Makefile.am
@@ -1,4 +1,4 @@
noinst_LIBRARIES = libray.a
-libray_a_SOURCES = ray_3f.h ray_camera.c ray_camera.h ray_color.h ray_euler.c ray_euler.h ray_light_emitter.h ray_object.h ray_object_light.h ray_object_plane.h ray_object_point.h ray_object_sphere.h ray_object_type.h ray_ray.h ray_render.c ray_render.h ray_render_object.h ray_render_object_plane.h ray_render_object_point.h ray_render_object_sphere.h ray_scene.h ray_surface.h
+libray_a_SOURCES = ray_3f.h ray_camera.c ray_camera.h ray_color.h ray_euler.c ray_euler.h ray_gamma.c ray_gamma.h ray_light_emitter.h ray_object.h ray_object_light.h ray_object_plane.h ray_object_point.h ray_object_sphere.h ray_object_type.h ray_ray.h ray_render.c ray_render.h ray_render_object.h ray_render_object_plane.h ray_render_object_point.h ray_render_object_sphere.h ray_scene.h ray_surface.h
libray_a_CFLAGS = -ffast-math
libray_a_CPPFLAGS = -I@top_srcdir@/src
© All Rights Reserved