summaryrefslogtreecommitdiff
path: root/src/libs/din/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2019-11-18 01:25:34 -0800
committerVito Caputo <vcaputo@pengaru.com>2019-11-18 01:54:33 -0800
commit975c81262faa7ed06de56974064fd918a088bc1b (patch)
treeb40620da4420fa3bd893593293edae211bdd9574 /src/libs/din/Makefile.am
parent9d2838a1a8685a5bd47a9f5296176171632a2f6f (diff)
libs/din: add a perlin noise implementation
This is a 3D noise field addressed as a unit cube. The caller supplies the resolution of the noise field in three dimensions. I've just pulled in my v3f.h here, but it probably makes sense to later on move vector headers into libs/ and share them. Later. It's called din as in noise, because it's shorter than perlin and noise.
Diffstat (limited to 'src/libs/din/Makefile.am')
-rw-r--r--src/libs/din/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/libs/din/Makefile.am b/src/libs/din/Makefile.am
new file mode 100644
index 0000000..b918de6
--- /dev/null
+++ b/src/libs/din/Makefile.am
@@ -0,0 +1,3 @@
+noinst_LIBRARIES = libdin.a
+libdin_a_SOURCES = din.c din.h v3f.h
+libdin_a_CPPFLAGS = -I@top_srcdir@/src
© All Rights Reserved