summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2023-08-28 18:57:55 -0700
committerVito Caputo <vcaputo@pengaru.com>2023-11-14 01:20:48 -0800
commitb22df31feeb7e695faabecfd7cc6fdd24609b0e1 (patch)
treeb1c33983aec45ba17de58276d2c3696695e573dd /src/Makefile.am
parent8245857f9f07043039affd7b92a740e002b1b81b (diff)
til: add preliminary audio backend
This is an early implementation of something resembling an audio backend for rototiller/libtil. The assumption for now is that everything will use signed 16-bit native-endian stereo output @ 44.1khz.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c6877a7..fda9b40 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,6 +6,10 @@ libtil_la_SOURCES = \
til.h \
til_args.c \
til_args.h \
+ til_audio.c \
+ til_audio.h \
+ til_audio_context.c \
+ til_audio_context.h \
til_builtins.c \
til_fb.c \
til_fb.h \
@@ -75,6 +79,7 @@ rototiller_SOURCES = \
fps.c \
fps.h \
main.c \
+ mem_audio.c \
mem_fb.c \
setup.c \
setup.h \
@@ -89,7 +94,7 @@ rototiller_SOURCES = \
til_util.h
if ENABLE_SDL
-rototiller_SOURCES += sdl_fb.c
+rototiller_SOURCES += sdl_audio.c sdl_fb.c
endif
if ENABLE_DRM
rototiller_SOURCES += drm_fb.c
© All Rights Reserved