summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2018-01-02 21:11:55 -0800
committerVito Caputo <vcaputo@pengaru.com>2018-02-22 14:26:10 -0800
commitd8948f3755d0b5bd199d80b60ece460ac61979f0 (patch)
tree29daa4badaa995c6ed1054c8bc800ea0be5c9465 /configure.ac
parentd58d959a94f24fa6f496380b1f085cda48560a63 (diff)
rototiller: wire up sdl video backend
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9c6eebb..9a53a1b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,6 +13,16 @@ LIBS="$PTHREAD_LIBS $LIBS"
CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
CC="$PTHREAD_CC"
+dnl Check for SDL
+SDL_VERSION=2.0.5
+AM_PATH_SDL2($SDL_VERSION,
+ :,
+ AC_MSG_ERROR([*** SDL version $SDL_VERSION not found!])
+)
+
+CFLAGS="$CFLAGS $SDL_CFLAGS"
+LIBS="$LIBS $SDL_LIBS"
+
AC_CONFIG_FILES([
Makefile
src/Makefile
© All Rights Reserved