summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@gnugeneration.com>2017-01-09 23:10:02 -0800
committerVito Caputo <vcaputo@gnugeneration.com>2017-01-10 08:23:54 -0800
commit65f1c4bbd7f7abff9469789f3ddc746caa1a3965 (patch)
treee83176b5cbea121386c2fbb00ddf4ec81ecd5f47 /configure.ac
parent6e284f6cfda2b436e7871d34367c3478aa211942 (diff)
*: preliminary autotools adoption
Builds were getting too time consuming, autotools is a very simple way to get incremental builds without having to dick with Makefiles myself.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..b7d0836
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,24 @@
+AC_INIT([rototiller], [1.0], [vcaputo@pengaru.com])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+AC_CONFIG_MACRO_DIRS([m4])
+AC_PROG_CC
+AM_PROG_CC_C_O
+AM_PROG_AR
+AC_PROG_RANLIB
+AM_SILENT_RULES([yes])
+PKG_CHECK_MODULES(ROTOTILLER, libdrm)
+
+AX_PTHREAD
+LIBS="$PTHREAD_LIBS $LIBS"
+CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
+CC="$PTHREAD_CC"
+
+AC_CONFIG_FILES([
+ Makefile
+ modules/Makefile
+ modules/ray/Makefile
+ modules/roto/Makefile
+ modules/sparkler/Makefile
+ modules/stars/Makefile
+])
+AC_OUTPUT
© All Rights Reserved