summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2018-05-03 01:11:39 -0700
committerVito Caputo <vcaputo@pengaru.com>2018-05-03 01:11:39 -0700
commitde8c678961226d0a7eb1f1276e8f5e842a33c3af (patch)
treebdfe3a077e651c60319dde62535185cde924d90d /configure.ac
*: initial commit derived from whale stage code
This code was used in whale [1], and prior to that was used in a smaller project called mal. Since I seemed to be doing a lot of reusing and building upon this, it seemed prudent to just stick it in a repo as a .a I could submodule in future SDL2 art projects. There are some kludges in this code currently, which will be fixed up in time.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..ac0e8b5
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,18 @@
+AC_INIT([libstage], [1.0], [vcaputo@pengaru.com])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+AC_PROG_CC
+AM_PROG_CC_C_O
+AM_PROG_AR
+AC_PROG_RANLIB
+AM_SILENT_RULES([yes])
+
+dnl Check for SDL2
+PKG_CHECK_MODULES(SDL2, sdl2)
+CFLAGS="$CFLAGS $SDL2_CFLAGS"
+LIBS="$LIBS $SDL2_LIBS"
+
+AC_CONFIG_FILES([
+ Makefile
+ src/Makefile
+])
+AC_OUTPUT
© All Rights Reserved