summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@gnugeneration.com>2016-09-01 09:14:34 -0700
committerVito Caputo <vcaputo@gnugeneration.com>2016-09-09 14:17:02 -0700
commitc42f6bb219a0af0d88dd3a66c605097b43566fb2 (patch)
tree50ca218005138f43317fff67a3755882a51ea004 /configure.ac
parent4642216f70dd98134a79f9299b7ca4bc876649c7 (diff)
build: Adopt GNU automake (and thus autotools)
Trying this out now that there's a pile of files... sigh. Note this spuriously duplicates list.h @ src/libvmon/list.h, the old Makefile shared list.h between vwm and libvmon, but I'm letting them have their own instances with autotools. Libvmon was always an independent project I just pulled in for vwm's use, and will likely continue to be developed independent of vwm with occasional syncs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..31770f5
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,16 @@
+AC_INIT([vwm], [3.0], [vcaputo@gnugeneration.com])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+AC_PROG_CC
+AM_PROG_AR
+AC_PROG_RANLIB
+AC_CONFIG_HEADERS([config.h])
+AM_SILENT_RULES([yes])
+
+PKG_CHECK_MODULES(VWM, x11 xext xinerama xrandr xcomposite xfixes xdamage xrender)
+
+AC_CONFIG_FILES([
+ Makefile
+ src/Makefile
+ src/libvmon/Makefile
+])
+AC_OUTPUT
© All Rights Reserved