summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVito Caputo <vcaputo@pengaru.com>2024-07-15 00:35:15 -0700
committerVito Caputo <vcaputo@pengaru.com>2024-08-13 23:36:43 -0700
commit9b05c41168842035ddcd377ed5e23bb862fb4a60 (patch)
tree60c480f891ed2a256c7c91083e7385f6e8666a86 /configure.ac
parent94a7020ad8c9efd9c5818eb3422ff4cb66a1b278 (diff)
charts: first stab at factoring out Xlib from charts/vmon
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 19 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 89acef5..6790b7a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,8 +7,25 @@ AC_PROG_RANLIB
AM_SILENT_RULES([yes])
AX_APPEND_COMPILE_FLAGS([-Wall])
-PKG_CHECK_MODULES(VWM, x11 xext xinerama xrandr xcomposite xfixes xdamage xrender)
-PKG_CHECK_MODULES(VMON, x11 xext xfixes xrender libpng)
+PKG_CHECK_MODULES(XWM_DEV, x11 xext xinerama xrandr xcomposite xfixes xdamage xrender,
+ AM_CONDITIONAL(ENABLE_VWM, declare build_vwm=true)
+ AC_DEFINE(HAVE_XWM_DEV, [1], [Define to 1 with X WM deps present]),
+ AM_CONDITIONAL(ENABLE_VWM, false)
+)
+
+PKG_CHECK_MODULES(XCLIENT_DEV, x11 xext xfixes xrender,
+ AM_CONDITIONAL(HAVE_XCLIENT_DEV, true)
+ AC_DEFINE(HAVE_XCLIENT_DEV, [1], [Define to 1 with X Client deps present]),
+ AM_CONDITIONAL(HAVE_XCLIENT_DEV, false)
+)
+
+PKG_CHECK_MODULES(PNG_DEV, libpng,
+ AM_CONDITIONAL(HAVE_PNG_DEV, true)
+ AC_DEFINE(HAVE_PNG_DEV, [1], [Define to 1 with libpng-dev present]),
+ AM_CONDITIONAL(HAVE_PNG_DEV, false)
+)
+
+AM_CONDITIONAL(ENABLE_VWM, [test "x$build_vwm" = xtrue])
AC_CONFIG_FILES([
Makefile
© All Rights Reserved