summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index de38d5f..400a0fb 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,3 +1,14 @@
noinst_LIBRARIES = libstage.a
-libstage_a_SOURCES = ../include/dll_h/dll.h stage.c stage.h
+noinst_PROGRAMS = stage-header
+
+libstage_a_SOURCES = ../include/dll_h/dll.h stage-private.h stage-public.h stage.c
libstage_a_CPPFLAGS = -I@top_srcdir@/include
+
+stage_header_SOURCES = ../include/dll_h/dll.h stage-private.h stage-header.c
+stage_header_CPPFLAGS = -I@top_srcdir@/include
+
+BUILT_SOURCES = stage.h
+CLEANFILES = stage.h
+
+stage.h: Makefile stage-header
+ @top_builddir@/src/stage-header >$@
© All Rights Reserved